Archive for EFSedan.com 1987 to 1991 Honda Civic Sedan Owners Club
 


       EFSedan.com Forum Index -> Interior/Exterior/Electrical
90efLS

Codes 9, 16 and 43 out of no where...

I just did the dpfi obd0 to mpfi obd1 wiring this week. Everything is good besides the code 9 I am getting. Checked all the wiring, used different dizzy and computer and searched the site and web for HOURS. Nothing seems to work. It runs on all cylinders...idle is good but gets iffy somewhat and it stutters on acceleration but rails after like 3 grand or so. Any help?
~Sp33~

I would definitely be checking the wiring at the distributor, make sure you've got it all right.
90efLS

All wiring at the dizzy is correct. I have went over it 4 times lol. I am going to give my ecu jumper a look over and the pinouts for the cyp wires. I ran them to c1 and c2 like all the write ups and diagrams say but I need to make sure my harness runs them to b15 and b16 on the p28 side. Any other suggestions tho? I heard that timing can throw a code 9 as well in some cases...
~Sp33~

I was thinking more along the lines of continuity between the wiring at the distributor, and throughout the harness.

Your ignition timing shouldn't be able to be out enough to throw any codes. Unless you changed the mechanical timing for some reason?

You say you searched and nothing worked, what did you try?
90efLS

New ecu, new dizzy, checked and re-checked the wiring. But...I have to solder and heat shrink the harness. It is all connected with butt connectors so I think there could be interference from somewhere also. I read that that could do it. I have been reading for hours about code 9. And I just got my car back from the exhaust shop and am now throwing code 43, fuel system. It wasn't popping that when the car went in. The car runs amazing tho...still searching lol
90efLS

So I am now getting codes 16 AND 43. 16 being injectors and 43 fuel supply system and its sounding like its running on 3 cylinders. But it drove fine all the way home and around town for the day. Then I park it and come back out to start it and its running rough and popping codes. grrrr. So now to check the injectors and fuel pump correct?

       EFSedan.com Forum Index -> Interior/Exterior/Electrical
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum